The Cross-Site Scripting Framework (XSSF) v-2.2 released.

changes v-2.2 :

  • New minor version compatible with new Metasploit Framework 4.4.
  • Minor changes thanks to Black Zero and time he took to fix the problem.

The Cross-Site Scripting Framework (XSSF)is a security tool designed to turn the XSS vulnerability exploitation task into a much easier work. The XSSF project aims to demonstrate the real dangers of XSS vulnerabilities, vulgarizing their exploitation. This project is created solely for education, penetration testing and lawful research purposes.

XSSF allows creating a communication channel with the targeted browser (from a XSS vulnerability) in order to perform further attacks. Users are free to select existing modules (a module = an attack) in order to target specific browsers.
XSSF provides a powerfull documented API, which facilitates development of modules and attacks. In addition, its integration into the Metasploit Framework allows users to launch MSF browser based exploit easilly from an XSS vulnerability.

In addition, an interesting though exploiting an XSS inside a victim’s browser could be to browse website on attacker’s browser, using the connected victim’s session. In most of cases, simply stealing the victim cookie will be sufficient to realize this action. But in minority of cases (intranets, network tools portals, etc.), cookie won’t be useful for an external attacker. That’s why XSSF Tunnel was created to help the attacker to help the attacker browsing on affected domain using the victim’s session.

Installation instructions:

  1. Download the latest Metasploit Framework (MSF) release:
  2. Install the MSF with the choosen database (PostgreSQL, MySQL or SQLite3):
  3. Update Ruby to 1.9 if not already done
  4. Download XSSF from the SVN (svn checkout xssf-read-only) or from the last packaged version
  5. Copy and paste all downloaded files into the Metasploit /msf3/ folder
  6. Enjoy!

Download : (1.6 MB)
Find Other Version |
Read more in here :