Faraday v1.0.22 - Collaborative Penetration Test and Vulnerability Management Platform.

Faraday v1.0.22 – Collaborative Penetration Test and Vulnerability Management Platform.

changelog v1.0.22:
+ GTK is the default interface now.
+ Added new plugin : Ndiff.
+ Added new plugin : Netcat (Gnu netcat – OpenBSD netcat – Original netcat)
+ Added button to edit your host in the GTK interface.
+ Hosts sidebar now can be sorted by amout of vulnerabilities and OS.
+ Changes in installation: install.sh now installs only GTK, QT is considered deprecated.
+ Changes in installation: Faraday now runs with the last versions of Python modules.
+ Changes in installation: fixed names of packages in setup_server.sh
+ Usability: Enter key in GTK dialogs works as OK button
+ Improved handling of lost connection to CouchDB database
+ First steps towards deprecating Filesystem databases
+ Fixed a bug when workspace was changed
+ Fixed a bug with Import Reports Dialog in GTK GUI on OS X.
+ Fixed a bug with Ctrl+Shift+C and Ctrl+Shift+V in some desktops managers.
+ Fixed a bug with mapper of vulnerabilities.faraday-v1-0-22

Faraday introduces a new concept (IPE) Integrated Penetration-Test Environment a multiuser Penetration test IDE. Designed for distribution, indexation and analysis of the generated data during the process of a security audit.
The main purpose of Faraday is to re-use the available tools in the community to take advantage of them in a multiuser way.

Collaborative Penetration Test and Vulnerability Management Platform

Collaborative Penetration Test and Vulnerability Management Platform

Designed for simplicity, users should notice no difference between their own terminal application and the one included in Faraday. Developed with a specialized set of functionalities that help users improve their own work. Do you remember yourself programming without an IDE? Well, Faraday does the same as an IDE does for you when programming, but from the perspective of a penetration test.

Faraday Restart Console

Faraday Restart Console

Requirements
Modern Linux or OSX, and the following packages:
+ Python 2.6.x or 2.7.x
+ Qt3 (only Linux)
+ CouchDB >= 1.2.0
+ The following python libs:
— mockito
— couchdbkit
— whoosh
— argparse
— psycopg2
— IPy
— requests

Installation:

Or

Download : v1.0.22.zipv1.0.22.tar.gz | Our Post Before
Source : http://www.faradaysec.com/